Wireless Service constantly rebooting after 6d upgrade

cyberpieman
Posts: 12
Joined: Fri Oct 21, 2011 6:54 pm

Wireless Service constantly rebooting after 6d upgrade

Post by cyberpieman » Fri Oct 21, 2011 9:11 pm

Pulling my hair out with this - after upgrading the firmware to 6d the wireless service constantly cycles making anything but wired connections impossible.

the syslog shows that the wireless NIC is constantly rebooting:

Oct 21 20:06:03 user kernel: Net device ra0 going down....
Oct 21 20:06:03 user kernel: rlk_inic_mbss_close --->
Oct 21 20:06:03 user kernel: setup MBSS[0] success
Oct 21 20:06:03 user kernel: all interfaces closed.
Oct 21 20:06:03 user kernel: rlk_inic_mbss_close <---
Oct 21 20:06:03 user kernel: iNIC Closing
Oct 21 20:06:03 user kernel: Delete HeartBeatTimer ....
Oct 21 20:06:03 user kernel: iNIC Closed
Oct 21 20:06:03 user kernel: br0: port 3(ra0) entering disabled state
Oct 21 20:06:09 user syslog: wps_btn&
Oct 21 20:06:09 user syslog: WSCScan&
Oct 21 20:06:09 user kernel: iNIC Open ra0
Oct 21 20:06:09 user kernel: ADDR0 = 10000008, ADDR1 = 10100008
Oct 21 20:06:09 user kernel: CMD = 0016, STATUS = 04a0
Oct 21 20:06:09 user kernel: LATENCY = 20, CACHE LINE SIZE = 08
Oct 21 20:06:09 user kernel: INT LINE = 39
Oct 21 20:06:09 user kernel: Reset Card
Oct 21 20:06:09 user kernel: ADDR0 = 10000008, ADDR1 = 10100008
Oct 21 20:06:09 user kernel: CMD = 0016, STATUS = 04a0
Oct 21 20:06:09 user kernel: INT LINE = 39
Oct 21 20:06:09 user kernel: ### LATENCY = 20, CACHE LINE SIZE = 08
Oct 21 20:06:09 user kernel: PDMA_RST_IDX = 0
Oct 21 20:06:09 user kernel: PDMA_GLO_CFG = 00000020
Oct 21 20:06:09 user kernel: TX_MAX_CNT0 = 00000080
Oct 21 20:06:09 user kernel: 2. reg = 00000020
Oct 21 20:06:09 user kernel: 2. PDMA_GLO_CFG = 00000065, reg = 00000065
Oct 21 20:06:09 user kernel: Op mode = 1
Oct 21 20:06:09 user kernel: BssidNum=1
Oct 21 20:06:09 user kernel: Wait for boot done...
Oct 21 20:06:09 user kernel: RACFG_CMD_BOOT_NOTIFY
Oct 21 20:06:09 user kernel: Open file: /etc/Wireless/RT2880/iNIC_ap.bin
Oct 21 20:06:09 user kernel: Open file: /var/iNIC_ap.dat
Oct 21 20:06:10 user kernel: RACFG_CMD_BOOT_INITCFG(0)
Oct 21 20:06:10 user kernel: RACFG_CMD_BOOT_INITCFG(1)
Oct 21 20:06:10 user kernel: RACFG_CMD_BOOT_INITCFG(2)
Oct 21 20:06:10 user kernel: Send Init Cfg Data Done(3 packets)
Oct 21 20:06:10 user kernel: RACFG_CMD_BOOT_UPLOAD(0)
Oct 21 20:06:10 user kernel: RACFG_CMD_BOOT_UPLOAD(1)
Oct 21 20:06:10 user kernel: RACFG_CMD_BOOT_UPLOAD(2)
Oct 21 20:06:10 user kernel:
Oct 21 20:06:10 user kernel: CRC:01 08 14 18 6d af c1 f5 22 32 2e 32 2e 30 2e 33 22 00 00 00 32 30 30 39 31 30 30 36 00 00 00 00 00 00 00 00 18 87 0a 00
Oct 21 20:06:10 user kernel: Send RT2880iNIC Firmware Done
Oct 21 20:06:10 user kernel: ===================================
Oct 21 20:06:10 user kernel: version: "2.2.0.3"
Oct 21 20:06:10 user kernel: size: 689944 bytes
Oct 21 20:06:10 user kernel: date: 20091006
Oct 21 20:06:10 user kernel: ===================================
Oct 21 20:06:10 user kernel:
Oct 21 20:06:10 user kernel: Send STARTUP to RT2880iNIC
Oct 21 20:06:10 user kernel: Close Firmware file
Oct 21 20:06:10 user kernel: RACFG_CMD_BOOT_STARTUP
Oct 21 20:06:11 user kernel: Update MAC(0)=00:04:ed:da:61:22
Oct 21 20:06:11 user kernel: br0: port 3(ra0) entering learning state
Oct 21 20:06:11 user kernel: br0: topology change detected, propagating
Oct 21 20:06:11 user kernel: br0: port 3(ra0) entering forwarding state
Oct 21 20:06:19 user syslog: wps_btn&
Oct 21 20:06:19 user syslog: WSCScan&

Repeat at will.....

Knocking back the firmware to 5 solves the problem, but that's not the point.

Has anyone any ideas ? Can I get in via telnet & delete a config file somewhere ?

Tomken
Posts: 467
Joined: Tue Jul 26, 2011 10:31 am
Location: Co Durham

Re: Wireless Service constantly rebooting after 6d upgrade

Post by Tomken » Fri Oct 21, 2011 10:39 pm

I thought that 1.06c was the forerunner to 1.06d - have you not done any f/w upgrades since 1.05 ?

I think what I would try prior to raising a ticket with /esupport, would be to do a factory reset with the 1.06d f/w installed and if that didn't resolve the issue, then revert back to the 5, delete the 6d .zip and .awf files from wherever they were downloaded to and then do a fresh f/w upgrade - restarting with Factory Settings button ticked > Save Config.

Did you download the 1.06d for the 7800N and not the 7800 - silly question maybe, but worth rechecking.

cyberpieman
Posts: 12
Joined: Fri Oct 21, 2011 6:54 pm

Re: Wireless Service constantly rebooting after 6d upgrade

Post by cyberpieman » Fri Oct 21, 2011 11:26 pm

version 5 of the firmware was the only one I had to hand to revert back to (I was on 6c when I did the original upgrade).

I've reset to factory & (re)inputted settings 'til I'm blue in the face. Even resetting, reverting to 5, reset to again then upgrade to 6d doesn't solve the problem.

No combination of resets has any effect, except to shunt up my frustration and stress levels. (Not helped by a BT engineer this aft who refused to install an VDSL MODEM 'cause quote "my router wasn't compatible" grrr :evil: - the BT Infinity hub is "state of the art" is it? I nearly hit the fool!)

There must be something that's not been written to the kernel by 6d that's causing the wireless service to fail - how do I reset the service? Is it possible? Or am I destined to sit at 5 until I throw the thing in the bin

Tomken
Posts: 467
Joined: Tue Jul 26, 2011 10:31 am
Location: Co Durham

Re: Wireless Service constantly rebooting after 6d upgrade

Post by Tomken » Sat Oct 22, 2011 1:03 pm

Other than raising a ticket with /esupport, all I can suggest is to switch the router off and then switch back on while holding in the reset at the rear of of the router for about 15-20secs.

This may clear what is snagging things up.

If you backup your config first (with the 1.05 f/w) then after the router has rebooted, restore with that config which should save you from having to re-input all the other settings and try the 1.06d upgrade again.

I have some superglue you can have to stick your hair back in with - if you like :)

Tomken
Posts: 467
Joined: Tue Jul 26, 2011 10:31 am
Location: Co Durham

Re: Wireless Service constantly rebooting after 6d upgrade

Post by Tomken » Sat Oct 22, 2011 3:17 pm

Came across this viewtopic.php?f=16&t=93 in the Firmware section by andyjrobinson.

It's a link for f/w 1.06e.RC3.afw

I've dowloaded and upgraded with it and other than an initial reluctance to pick up the wireless after shutting down, disconnecting the cable and rebooting the laptop wirelessly, then a router restart on Current Settings, everything is working fine.

The only additional settings other than for the ISP is a static IP for the printer and this checks out with the router reboot and a reboot via telnet - although they were before the f/w upgrade.

It may be worth giving it a try and forgoing the 1.06d

cyberpieman
Posts: 12
Joined: Fri Oct 21, 2011 6:54 pm

Re: Wireless Service constantly rebooting after 6d upgrade

Post by cyberpieman » Sat Oct 22, 2011 9:22 pm

No, 6e didn't work.
It's defo something in the 6x configuration that my machine don't like.

Ticket raised with support, so I'll just wait & see if there's anyone at home who has half a clue.

In the meantime....find wall, bang head :cry:

mhoullier
Posts: 2
Joined: Sun Oct 23, 2011 7:49 pm

Re: Wireless Service constantly rebooting after 6d upgrade

Post by mhoullier » Sun Oct 23, 2011 8:43 pm

I'm also getting constant restarting after upgrading to 6d. The log does not show anything other than just a restart, randomly. I've tried upgrading to the 6e.RC3 but that also produces random restarting. I've performed reset etc. as suggested.

The config is:

ADSL MPoA 0/101
LLC/Snap bridging
BeUnlimited (ADSL2) 2Mbit link.

I bought this to replace the BeUnlimited standard box since I was after stability, but the Billion router makes the BeUnlimited box look rock solid!

roseway
Posts: 10
Joined: Tue Aug 23, 2011 11:05 am

Re: Wireless Service constantly rebooting after 6d upgrade

Post by roseway » Mon Oct 24, 2011 4:18 pm

One thing I would add to the above is to check your wireless settings, and in particular the mode setting. Mine (with 1.06d) is on g + n and has no stability problems, but maybe there are problems with some other combinations of mode setting and connected equipment.

mhoullier
Posts: 2
Joined: Sun Oct 23, 2011 7:49 pm

Re: Wireless Service constantly rebooting after 6d upgrade

Post by mhoullier » Tue Oct 25, 2011 8:56 am

I think the ADSL mode was causing the restarting.
I did the following and it's been up for 12 hours, which is the longest since around August.

Turned off any extra options, such as ADSL+, dmt, Annex M etc..
Disconnected the ADSL line
Started up the router
Reconnected the ADSL line.

Tomken
Posts: 467
Joined: Tue Jul 26, 2011 10:31 am
Location: Co Durham

Re: Wireless Service constantly rebooting after 6d upgrade

Post by Tomken » Tue Oct 25, 2011 11:46 am

Regardless of the mode the routers are now set at, if this problem didn't occur until after the f/w upgrade, then the 6d is causing a conflict as shown in the original post.

I no longer have the text that came with the upgrade that described the mods, but that is where the answer should lay.

Post Reply