Not very good at attempting to auto-reconnect?

Post Reply
Salty_Wagyu
Posts: 27
Joined: Fri Aug 05, 2011 1:24 pm

Not very good at attempting to auto-reconnect?

Post by Salty_Wagyu » Fri Nov 04, 2011 12:26 pm

Whenever I lose sync with my local exchange, or a BT hostlink goes down, or I change a setting on the WAN > ADSL Mode page and Apply, it is unable to get reconnected to my ISP once the adsl sync is back up. This is spammed in the System Log instead:

Code: Select all

Oct 21 11:30:38  daemon  pppd[1465]: Couldn't increase MTU to 1500.
  Oct 21 11:30:38  daemon  pppd[1465]: PPP LCP UP.
  Oct 21 11:30:38  daemon  pppd[1465]: LCP terminated by peer
  Oct 21 11:30:38  daemon  pppd[1465]: LCP terminated by peer
  Oct 21 11:30:38  daemon  pppd[1465]: Couldn't increase MTU to 1500.
  Oct 21 11:30:41  daemon  pppd[1465]: Connection terminated.
  Oct 21 11:30:44  daemon  pppd[1465]: PPP: Start to connect ...
  Oct 21 11:30:46  daemon  pppd[1465]: Using interface ppp0_0_38_1
  Oct 21 11:30:46  daemon  pppd[1465]: Connect: ppp_0_0_38_1 <-->
  Oct 21 11:30:46  daemon  pppd[1465]: Couldn't increase MTU to 1500.
  Oct 21 11:30:46  daemon  pppd[1465]: PPP LCP UP.
  Oct 21 11:30:46  daemon  pppd[1465]: LCP terminated by peer
  Oct 21 11:30:46  daemon  pppd[1465]: LCP terminated by peer
  Oct 21 11:30:46  daemon  pppd[1465]: Couldn't increase MTU to 1500.
  Oct 21 11:30:49  daemon  pppd[1465]: Connection terminated.
  Oct 21 11:30:52  daemon  pppd[1465]: PPP: Start to connect ...
  Oct 21 11:30:53  daemon  pppd[1465]: Using interface ppp0_0_38_1
  Oct 21 11:30:53  daemon  pppd[1465]: Connect: ppp_0_0_38_1 <-->
  Oct 21 11:30:53  daemon  pppd[1465]: Couldn't increase MTU to 1500.
  Oct 21 11:30:53  daemon  pppd[1465]: PPP LCP UP.
  Oct 21 11:30:53  daemon  pppd[1465]: LCP terminated by peer
  Oct 21 11:30:53  daemon  pppd[1465]: LCP terminated by peer
  Oct 21 11:30:53  daemon  pppd[1465]: Couldn't increase MTU to 1500.
  Oct 21 11:30:56  daemon  pppd[1465]: Connection terminated.
That day, a BT hostlink was apparently down for only 15 minutes during the night according to my ISP forums, but this router was unable to reconnect for 7 hours until I woke up and manually rebooted it.


On a manual reboot, it reconnects just fine, with the same ADSL settings as before:

Code: Select all

  Jan 01 00:00:33  user  kernel: Line 0: ADSL link up, interleaved, us=448, ds=3680
  Jan 01 00:00:33  daemon  pppd[599]: PPPoATM setdevname_pppoatm
  Jan 01 00:00:33  daemon  pppd[599]: PPPoATM setdevname_pppoatm - SUCCESS
  Jan 01 00:00:33  daemon  dnsmasq[92]: using nameserver 8.8.4.4#53
  Jan 01 00:00:33  daemon  dnsmasq[92]: using nameserver 8.8.8.8#53
  Jan 01 00:00:33  daemon  pppd[599]: pppd 2.4.1 started by admin, uid 0
  Jan 01 00:00:33  user  kernel: br0: port 1(eth0) entering disabled state
  Jan 01 00:00:35  daemon  pppd[599]: PPP: Start to connect ... 
  Jan 01 00:00:35  daemon  pppd[599]: Using interface ppp0_0_38_1
  Jan 01 00:00:35  daemon  pppd[599]: Connect: ppp_0_0_38_1 <--> 
  Jan 01 00:00:35  daemon  pppd[599]: Couldn't increase MTU to 1500.
  Jan 01 00:00:37  daemon  DHCP SERVER: DHCP request from 90:e6:ba:2d:61:f1
  Jan 01 00:00:37  daemon  DHCP SERVER: DHCP ack to 90:e6:ba:2d:61:f1
  Jan 01 00:00:38  daemon  pppd[599]: PPP LCP UP. 
  Jan 01 00:00:41  daemon  DHCP SERVER: DHCPINFORM from 192.168.1.100
  Jan 01 00:00:43  daemon  pppd[599]: local  IP address <removed>
  Jan 01 00:00:43  daemon  pppd[599]: remote IP address <removed>
  Jan 01 00:00:43  daemon  pppd[599]: primary   DNS address 212.69.40.3
  Jan 01 00:00:43  daemon  pppd[599]: secondary DNS address 212.69.36.3
How do I fix this problem? I'm on 1.06d but the new 1.06e firmware release notes does not note anything in the changelog which would be relevant to this issue. This has occured on 2 Billion 7800N routers as well, the first which was replaced due to faulty Wi-Fi.

I'm on ADSL Max, I have disabled ADSL2/ADSL2+ features, and enabled SRA/PhyR but this doesn't make a difference.
You do not have the required permissions to view the files attached to this post.

billion_fan
Posts: 5294
Joined: Tue Jul 19, 2011 4:30 pm

Re: Not very good at attempting to auto-reconnect?

Post by billion_fan » Fri Nov 04, 2011 1:56 pm

Which ISP are you with??

Anychance you are with Plusnet???

Salty_Wagyu
Posts: 27
Joined: Fri Aug 05, 2011 1:24 pm

Re: Not very good at attempting to auto-reconnect?

Post by Salty_Wagyu » Fri Nov 04, 2011 5:56 pm

I'm with IDNet

billion_fan
Posts: 5294
Joined: Tue Jul 19, 2011 4:30 pm

Re: Not very good at attempting to auto-reconnect?

Post by billion_fan » Sat Nov 05, 2011 12:52 pm

Not sure if this will work but it maybe worth a try.

Go to the basic menu and click on 'WAN' change the protocol to 'PPPOE' and Encap Method to 'LLC/SNAP', make sure all other settings are correct eg username, password, VPI, VCI etc

Click on 'Apply' the the modem should save and reboot.

Now check if you can connect using this different protocol, if you can, another quick test will be to make a WAN change or dropping the ADSL sync and once it resyncs see if it will reconnect without a power cycle.

Double Six
Posts: 4
Joined: Mon Aug 08, 2011 12:49 am

Re: Not very good at attempting to auto-reconnect?

Post by Double Six » Sat Nov 05, 2011 12:56 pm

With PlusNet it works fine if protocol is set to PPoE and encap. set to LLC. So, you might try this.

Also, untick PhYr - it's not supported by BT exchanges and is a TV streaming technology that has not been widely taken up. I don't use it and presently I don't use SRA, although I have tried SRA on the advice of a PlusNet advisor.

I'm still not sure about SRA because it doesn't seem to make any difference long-term. I think BT exchanges have their own version these days anyway and I suppose it's possible it could clash.

66

Double Six
Posts: 4
Joined: Mon Aug 08, 2011 12:49 am

Re: Not very good at attempting to auto-reconnect?

Post by Double Six » Sat Nov 05, 2011 12:58 pm

Hoho billionfan. You beat my reply by 4 minutes!

66

Salty_Wagyu
Posts: 27
Joined: Fri Aug 05, 2011 1:24 pm

Re: Not very good at attempting to auto-reconnect?

Post by Salty_Wagyu » Sat Nov 05, 2011 6:14 pm

Thanks, will try those suggestions in the daytime, it's evening now and I'd risk having my IP profile dropped to lower speeds due to the low SNR :)

Salty_Wagyu
Posts: 27
Joined: Fri Aug 05, 2011 1:24 pm

Re: Not very good at attempting to auto-reconnect?

Post by Salty_Wagyu » Sun Nov 06, 2011 12:25 pm

PPPoE and LLC/SNAP works fine to connect to IDNet, and I also forced a line sync drop to see if it would reconnect PPP without any looping errors in system log and it did :)

Thanks :D

Post Reply