7800N Wireless Card Not Detected

Post Reply
denzity
Posts: 1
Joined: Fri Dec 23, 2011 8:14 am

7800N Wireless Card Not Detected

Post by denzity » Fri Dec 23, 2011 8:17 am

I just purchased a new 7800N and I have a very weird logon page, in that everything is normal except that there is no wireless menu.

I know I could do the easy thing and RMA, but I don't want to wait for weeks (especially given the time of year), and I think that a fix may be possible.

Image

After I power the router on I goto the syslog and see the following:

Code: Select all

Jan 01 00:00:11  user  kernel: rt2880_iNIC: falsely claims to have parameter csumoff
  
Jan 01 00:00:11  user  kernel: RT2880iNIC: 802.11n WLAN PCI driver v2.2.0.1 (Aug. 10, 2009)
  
Jan 01 00:00:11  user  kernel: RT2880iNIC: pci dev 0000:00:01.0 (id 1814:0801 rev 01)
  
Jan 01 00:00:11  user  kernel: RT2880iNIC: no MMIO resource for pci dev 0000:00:01.0
  
Jan 01 00:00:11  user  kernel: RT2880iNIC: probe of 0000:00:01.0 failed with error -5
What does it mean by 'no MMIO resource?'
Does the error code -5 arise from pci_enable_device() failing?

Perhaps if I could re-write the firmware on the wireless card it would fix it, however I have no idea how to - ideas anyone?

Obviously I've done all the 'normal' debugging like flashing firmware, reset to factory, hard-reset etc. but to no avail. Any help would be greatly appreciated.

Thanks

billion_fan
Posts: 5294
Joined: Tue Jul 19, 2011 4:30 pm

Re: 7800N Wireless Card Not Detected

Post by billion_fan » Fri Dec 23, 2011 9:24 am

Hi denzity

Please RMA the device with your supplier.

It seems the wireless card has failed on your unit, as there is no option to see the wireless menu.

Normally swapping the wireless card will resolve the issue, meaning the firmware is not a issue, the wireless card itself is suffering from a hardware failure.

Post Reply