Page 1 of 1

Odd Connectivity issues -- max hosts?

Posted: Sun May 10, 2020 11:10 am
by watcher60
I'm presuming the recommendation will be to perform a firmware upgrade but thought I would post to see if anyone else had run in to similar issues, or pointers on anything to try/check.

Background is I recently picked up a second hand 7800DXL as the technicolor router provided by the ISP would randomly crash and reboot when using the 4g (I live in the sticks with the landline giving 2Mbps, so use a 4G huawei E3372h dongle and update the default gw to cut over to the 4g without having to disconnect the dsl). I do have a further two wifi access points connected over powerline plugs in different areas of the house (old stone cottage so needed).

The 7800DXL per the status page is running 2.32e, and the setup is mainly at the defaults, bar the dsl username/pw settings and the WIFI SSID with psk (WPA2-PSK with AES). The 4G dongle seems to have been detected and worked out of the box, currently setup as a the failover backup though have unticked the dial on demand as I sometime route work related IP connections over it while keeping the rest of the house on the DSL. It is acting as the DHCP server on the network. Given the lock down and being a family of 5 adults with a few alexa devices there can be approx 30 devices connected to the network though only about 10 using the 78000DXL as the wifi access point


Upon boot I have found that the router if the 4G dongle is connected does not detect the dongle and I have to reconnect for the router to detect it -- this is more an annoyance than a major issue.

On a fresh boot all seems happy however after a few hours I notice devices are unable to connect to the 7800DXL wifi (my iphone state "incorrect password"), other devices already connected seem to be fine. Rebooting the router seems to return normality but the issue eventually re-occurs. On one occasion where I was unable to connect using my laptop, I tried connecting via an ethernet port on the 7800DXL, while I was able to obtain a DHCP IP access to the mgmt page on the 7800DXL times out, as did access via SSH (I was able to telnet to the SSH port but it did not return a banner -i.e. it was as if the port was open and held the connection but did not return any data which a wireshark capture also indicated--- should make clear I know you use a SSH client to connect just using telnet for a basic port check). This I have to admit has muddied the waters as I presumed it was just a WIFI issue but appears to point more general issue with the 7800DXL. The only time I have seen similar is where either a server is struggling or there is asymmetrical routing through a stateful firewall so UDP/ICMP passes but TCP is being blocked

I know in the WIFI settings there is a max number of hosts (set to the max 16) but is there a known limitation outside of the WIFI that the 7800DXL can handle on the network? Any particular logs/cmds or config tweaks I should be trying to run on the 7800DXL to identify the cause of the issue?

thanks in advance

Re: Odd Connectivity issues -- max hosts?

Posted: Tue May 12, 2020 5:33 pm
by watcher60
Just to close out - the firmware upgrade did seem to resolve the issue. I did lose SSH/Web gui mgmt access following the initial config after about 30mins but a reboot restored and has been stable since